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Step-by-step procedures

Map of screen elements

Step-by-step procedures
The topics below provide step-by-step instructions for working with PalEdit.

Working with palette files
Applying a palette file to a bitmap
Creating a palette file
Opening a palette file
Opening PalEdit
Saving palette files
Customizing PalEdit
Changing the palette view
Setting preferences
Selecting colors from the palette
Deselecting color cells
Identifying a palette colors in a bitmap
Selecting color cells
Selecting colors from BitEdit
Selecting similar colors
Selecting unused colors
Editing colors
Adding a color to a palette
Copying and pasting color cells
Defining a color
Deleting color cells
Editing a color in a palette
Merging selected color cells
Moving color cells
Modifying palette structure
Tinting or filtering an entire palette
Adjusting palette brightness
Adjusting palette contrast
Creating an identity palette
Cycling hue sequences in a palette
Cycling palette colors
Fading a palette to a specific color
Fading a palette to a second palette
Reordering an entire palette



PalEdit
Click elements on the PalEdit screen below to display descriptions of screen elements.



View Order combo box
Palette Order Lists colors in the order they are stored in the palette file.
Brightness Lists colors by brightness, placing the lightest colors at the top, from left to right, and the 

darkest colors at the bottom. Changing the viewing order affects only the appearance of the 
palette in PalEdit and does not restructure the palette file.

Darkness Lists colors by darkness, placing the darkest colors at the top, from left to right, and the lightest
colors at the bottom. Changing the viewing order affects only the appearance of the palette in 
PalEdit and does not restructure the palette file.

Color Sort Places colors with similar RGB values together. Changing the viewing order affects only the 
appearance of the palette in PalEdit and does not restructure the palette file.

Bitmap Occurrence Lists colors used in a bitmap by their frequency of appearance, placing the colors used most at
the top, from left to right. The colors used least are placed at the bottom. Changing the viewing
order affects only the appearance of the palette in PalEdit and does not restructure the palette 
file. This option appears only when you are viewing a bitmaps associated palette file. 



Palette area
Color cells appear in this area. PalEdit displays defined color cells at the top of the palette area, from left to right. 
Empty color cells are displayed last and appear as gray swatches.



New
Open From
Update/Save
Save As
Apply From File
Save To File
Exit



Undo
Cut
Copy
Paste
Delete
Select All
Select Similar Colors
Select Unused Colors
Flash Selected Colors
Merge Selected Colors
Preferences



Edit Color
Add Color
Reorder Palette as View/Copy View
Make Identity Palette



Adjust Brightness
Adjust Contrast
Add Selected Color
Fade To Selected Color
Fade To Palette
Cycle RGB
Cycle Palette



New (PalEdit)
File menu

Keyboard: Ctrl+N

Displays the New Palette dialog box. Closes the current palette and prompts you to save or update the current 
palette file if you have not already done so.

Option Description
Number of initial palette entries Entering a number sets the number of defined colors there are in the new 

palette. You can add colors at any time.



Open From (PalEdit)
File menu

Opens an existing palette file. This command is dimmed when you open PalEdit from BitEdit. If you are working on
a palette, you are prompted to save or update it if you have not already done so. From the submenu you can 
choose:

Current Book. Opens a palette file stored in the ToolBook book currently open. This command is only 
available when you open PalEdit from ToolBook.

Other Book. Opens a palette file stored in a ToolBook book that is not currently open.

File. Opens a palette file stored in Microsoft Palette format (.PAL).



Update/Save (PalEdit)
File menu

Keyboard: Ctrl+S

Both the Update and Save commands save the palette file you have open to the book or file where it was saved 
previously.
Update only appears when you open a palette file that is already imported as a resource into a ToolBook book.
Save only appears when you open a standalone palette file. If the file has not yet been saved, the Save As dialog 
box appears.



Save As (PalEdit)
File menu

Saves the palette you're working on for the first time or as a new file in a new location. You can save it as a 
resource in a ToolBook book or as a standalone file. From the submenu, you can choose

Palette In Current Book. Saves the palette file as a resource in the current ToolBook book. This command is 
available only when you open PalEdit from ToolBook.

Palette In Other Book. Saves the palette file as a resource in a ToolBook book that is not currently open.

File. Saves the palette file as a standalone file.



Apply From File (PalEdit)
File menu

Applies the colors from a palette file you specify to the bitmap you are currently editing. This command is only 
available when you open PalEdit from BitEdit.



Save To File (PalEdit)
File menu

Creates a palette file from the palette of the bitmap you are currently editing. This command is only available when
you open PalEdit from BitEdit.



Exit (PalEdit)
File menu

Keyboard: Alt+F4

Closes PalEdit. Prompts you to save or update the current image if you have not already done so.



Undo (PalEdit)
Edit menu

Keyboard: Alt+BkSp

Undoes the last complete operation.



Cut (PalEdit)
Edit menu

Keyboard: Ctrl+X

Removes a selected cell or group of cells from the palette and places the selection on the Windows Clipboard. 
When nothing is selected, the command is dimmed on the menu.



Copy (PalEdit)
Edit menu

Keyboard: Ctrl+C

Copies a selected cell or group of cells from the palette and places the selection on the Windows Clipboard. When
nothing is selected, the command is dimmed on the menu.



Paste (PalEdit)
Edit menu

Keyboard: Ctrl+V

Pastes the contents of the Windows Clipboard into the palette. When the Clipboard contains anything other than a 
palette or bitmap, the command is dimmed on the menu.



Delete (PalEdit)
Edit menu

Keyboard: Del

Removes the current selection without placing it on the Windows Clipboard. When nothing is selected, the 
command is dimmed on the menu.



Select All (PalEdit)
Edit menu

Keyboard: Ctrl+A

Selects all cells in the palette.



Select Similar Colors (PalEdit)
Edit menu

Displays the Select Similar Colors dialog box. You can select cells containing colors with RGB values similar to a 
selected cell. When nothing is selected, the command is dimmed on the menu.

Option Definition
Scroll bar Moving the scroll bar slider from 1 to 4 indicates the number of colors you want to 

select.
Number Of Selected Colors Entering a number from 1 to 4 indicates the number of colors you want to select.



Select Unused Colors (PalEdit)
Edit menu

Selects the color cells that are not used by the bitmap currently displayed in BitEdit. This command is only 
available when you open PalEdit from BitEdit.



Flash Selected Colors (PalEdit)
Edit menu

Keyboard: F2

When one or more color cells in PalEdit are selected, shows where the colors are used in a bitmap opened in 
BitEdit. BitEdit briefly inverts the selected colors in the bitmap, so that they appear to flash. This command is only 
available when you open PalEdit from BitEdit.



Merge Selected Colors (PalEdit)
Edit menu

Keyboard: F3

Blends together two or more selected colors to create a single color that replaces the selected color cells. When 
nothing is selected, the command is dimmed on the menu.



Preferences (PalEdit)
Edit menu

Displays the PalEdit Preferences dialog box. Changes you make in this dialog box take effect immediately.

Option Definition
Dual View Displays two views of a palette, each of which can display a different viewing order. When this 

option is checked, PalEdit shows colors you select in both views.
Delay Updates Prevents PalEdit from automatically reflecting the changes you make to a palette in BitEdit. 

When this option is checked, PalEdit does not recalculate the palette for each bitmap change, 
so you don't have to wait for the palette to update before continuing.



Edit Color (PalEdit)
Palette menu

Displays the Edit Color dialog box. To edit a color, you can modify either the red, green, and blue (RGB) values of 
the color, or the hue, saturation, and luminance (HSL) values. As you edit the color, the new color is displayed in 
the Color refiner box.

Option Definition
Color grid Displays all the colors that can be displayed on your system. Moving the cursor changes the 

color displayed in the Color refiner box.
Vertical slider bar Moving the slider adjusts the luminosity of the color you are editing. Moving the slider up 

lightens the color; moving it down darkens the color.
Color refiner box Displays the resulting color as you make changes in the dialog box.
Hue Entering a number from 0 to 239 adjusts the quality of the color, reflected by the cursor 

moving horizontally across the color grid from red through yellow, green, cyan, blue, and 
magenta. Higher numbers move the cursor right; lower numbers move it left.

Sat Entering a number from 0 to 239 adjusts the intensity of the color, reflected by the cursor 
moving vertically across the color grid. Higher numbers move the cursor up, making the 
color more intense; lower numbers move it down.

Lum Entering a number from 0 to 239 adjusts the luminosity of the color, reflected by the slider 
moving on the vertical slider bar. Higher numbers move the slider up, making the color 
lighter; lower numbers move it down.

Red Entering a number from 0 to 255 adjusts how much red is in the color.
Green Entering a number from 0 to 255 adjusts how much green is in the color.
Blue Entering a number from 0 to 255 adjusts how much blue is in the color.



Add Color (PalEdit)
Palette menu

Displays the Add Color dialog box. you can modify either the red, green, and blue (RGB) values of the color, or the
hue, saturation, and luminance (HSL) values. As you modify the color, the new color is displayed in the Color 
refiner box..

Option Definition
Color grid Displays all the colors that can be displayed on your system. Moving the cursor changes the 

color displayed in the Color refiner box.
Vertical slider bar Moving the slider adjusts the luminosity of the color you are editing. Moving the slider up 

lightens the color; moving it down darkens the color.
Color refiner box Displays the resulting color as you make changes in the dialog box.
Hue Entering a number from 0 to 239 adjusts the quality of the color, reflected by the cursor 

moving horizontally across the color grid from red through yellow, green, cyan, blue, and 
magenta. Higher numbers move the cursor right; lower values move it left.

Sat Entering a number from 0 to 239 adjusts the intensity of the color, reflected by the cursor 
moving vertically across the color grid. Higher numbers move the cursor up, making the color 
more intense; lower numbers move it down.

Lum Entering a number from 0 to 239 adjusts the luminosity of the color, reflected by the slider 
moving on the vertical slider bar. Higher numbers move the slider up, making the color lighter;
lower numbers move it down.

Red Entering a number from 0 to 255 adjusts how much red is in the color.
Green Entering a number from 0 to 255 adjusts how much green is in the color.
Blue Entering a number from 0 to 255 adjusts how much blue is in the color.



Reorder Palette as View/Copy View (PalEdit)
Palette menu

Reorders the entire structure of a palette to match a viewing order. When PalEdit is displaying dual view, the menu
command changes to Copy View.



Make Identity Palette (PalEdit)
Palette menu

Transforms a palette into an identity palette that contains the 20 system colors reserved by Windows in addition to 
the bitmap's colors. PalEdit inserts the reserved system colors into the first 10 and last 10 cells of a 256-color 
palette.
When your palette contains more than 236 colors, PalEdit truncates the palette's bottom 20 colors to make room 
for the system colors, then remaps deleted colors to the closest remaining colors in the palette.



Adjust Brightness (PalEdit)
Effects menu

Displays the Adjust Brightness dialog box, in which you can change lighten or darken all the colors in the palette 
by a fixed amount.

Option Definition
Scroll bar Moving the scroll bar slider from 0 to -255 darkens the colors; moving it from 0 to 

255 lightens the colors.
Number Of Selected Colors Entering a number from 0 to -255 darkens the colors; moving it from 0 to 255 

lightens the colors.



Adjust Contrast (PalEdit)
Effects menu

Adjusts a palette's contrast to increase or decrease the distinction between light and dark colors. PalEdit changes 
the luminance and red, green, and blue values for each color in a palette by a percentage you specify. Increasing 
the contrast lightens colors that are lighter than a median gray and darkens remaining colors. Decreasing the 
contrast fades all colors to a median gray.

Option Definition
Scroll bar Moving the scroll bar slider from 0 to -255 darkens the colors; moving it from 0 to 

255 lightens the colors.
Number of Selected Colors Entering a number from 0 to -255 darkens the colors; moving it from 0 to 255 

lightens the colors.



Add Selected Color (PalEdit)
Effects menu

Adds RGB values of a selected color to all colors in a palette. You can tint a palette to add a specified color to all 
the cells, causing one color to dominate your bitmap. Or you can filter out a specified color from the cells of a 
palette.



Fade To Selected Color (PalEdit)
Effects menu

Converges all the colors in the palette toward the RGB values of one color or a selection of colors, based on the 
percentage you specify. For example, if you fade all colors in a palette to 50% red, every color in the palette 
changes to a color halfway between the original color and the target color or colors. For example, a yellow would 
become orange.



Fade To Palette (PalEdit)
Effects menu

Converges all the colors in the palette toward similar colors in a specified palette, based on a percentage you 
specify. For each color cell of the currently displayed palette, PalEdit selects a target color (the closest matching 
color) from the second palette, then fades the color cell to that target color at the percentage you enter in the Fade
to Palette dialog box.



Cycle RGB (PalEdit)
Effects menu

Cycles all the colors in the palette through the hues of the color wheel based on a percentage you specify. White, 
gray, and black are not affected. For example, a true red (R=255, G=0, B=0) is changed to its opposite color, a 
blue-green, (R=0, G=123, B=131) when you cycle the RGB values 50 percent.



Cycle Palette (PalEdit)
Effects menu

Cycles colors among a series of cells that you specify.



Opening PalEdit
Step-by-step

PalEdit allows you to create new, or modify existing palette files.

To open PalEdit as a standalone application:

Double-click the PalEdit icon in the Program Manager.
To open PalEdit from ToolBook:
1 Choose Resources from the Object menu to open the Resource Manager dialog box.
2 Under Available Resources, choose Palette, then click New.

To open PalEdit from BitEdit:

Choose Show Palette from the Options menu.



Opening a palette file
Step-by-step

You can open palette files stored in Microsoft Palette format (.PAL). You can also open bitmap and digital video 
files stored in the following formats to edit their palettes: bitmap (.BMP), device-independent bitmap (.DIB), 
Microsoft RIFF DIB (.RDI), or audio/visual interleaved format (.AVI).

To open a .PAL file:
1 Open PalEdit from ToolBook or as a standalone application.
2 Choose Open From from the File menu. Choose the source of the bitmap from the submenu menu:

File. Opens the standard Windows Open File dialog box. Select the file you want, then click OK to open it.

Other Book. Opens the Choose Book dialog box. When you choose a book, the Choose Palette dialog box 
appears. Select the palette you want, then click OK.

Current Book. Opens the Choose Palette dialog box. Choose the palette you want, then click OK. Current 
Book is only available when you open PalEdit from a ToolBook book.

To open a bitmaps palette:
1 Open BitEdit then open the image whose palette you want to open.
2 Choose Show Palette from the Options menu.

Note The Open From command is dimmed when you open PalEdit from BitEdit because you can open only the 
palette associated with the open bitmap.



Step-by-step
Opening PalEdit
Menu Commands
Open From (PalEdit)



Creating a palette file
Step-by-step

You can create a new palette file in Microsoft Palette format (.PAL). For example, you can create a new palette file 
to associate a specific set of colors with a group of bitmaps used in a presentation or multimedia application.

To create a new palette file:
1 Open PalEdit from ToolBook or as a standalone application.
2 Choose New from the File menu.
3 In the Number of Initial Palette Entries box, enter a number between 2 and 256 for the number of color 

definitions you want the palette to have.
4 Click OK.

Tip You can add colors to your palette at any time.



Step-by-step
Adding a color to a palette
Opening PalEdit



Saving palette files
Step-by-step

You can save palette files in Microsoft Palette format (.PAL) or you can save them as resources in a ToolBook 
book. You can apply both .PAL and .TBK files to a bitmap image.

To save a palette as a .PAL file:
1 Open PalEdit and open the palette you want to save.
2 Choose Save As File from the File menu if you opened PalEdit from ToolBook or as a standalone application.

If you opened PalEdit from BitEdit, choose Save To File from the File menu.
3 Under File Name, enter a name of up to eight characters for the palette file.
4 Under Directories, select a new path to save the file in a directory other than the current one.
5 Click OK.

To save a palette as a resource to a .TBK file:
1 Open PalEdit and open the palette you want to save.
2 If you opened PalEdit

from ToolBook, choose Save As from the File menu, then choose Palette In Current Book or Palette In Other
Book.

as a standalone application, choose Save As Palette In Other Book.

from BitEdit, choose Save To File.
3 Choose ToolBook Palette in the Save File As Type box.
4 Under File Name, enter the name of the Toolbook (.TBK) file to which you want to save the palette file. Or, 

double-click the .TBK file name in the box (even if it is dimmed).
5 If you choose Save As Palette In Other Book in Step 2, PalEdit will ask you to verify that you want to replace 

the existing file. Click Yes.
6 Specify a name for the resource, then click OK.



Step-by-step
Applying a palette file to a bitmap
Fading a palette to a second palette
Opening PalEdit



Applying a palette file to a bitmap
Step-by-step

You can apply a palette file to a bitmap. For example, you can apply one palette to several bitmaps that will be 
displayed together in an application. You can apply any palette stored as a .PAL file, as a resource in a ToolBook 
book, or as a resource in another bitmap. The palette you apply replaces the bitmap's original palette.

To apply a palette to a bitmap:
1 Open BitEdit, then open the bitmap file that you want to assign a palette to.
2 To open PalEdit, choose Show Palette from the Options menu.
3 From the PalEdit File menu, choose Apply From File.
4 Under List Files Of Type, select the file format you want.
5 Under File Name, type the name of the file you want to open. Or, double-click a file name in the box.
6 Click OK.
7 If you are applying a palette from a ToolBook book, choose the palette you want in the Choose Palette dialog 

box, then click OK.
8 PalEdit asks you to verify that you want to apply the palette from the file. Click OK to apply the palette.



Step-by-step
Fading a palette to a second palette
Opening PalEdit



Setting preferences
Step-by-step

You can customize PalEdit's working environment.

To set PalEdit preferences:
1 Open PalEdit.
2 Choose Preferences from the Edit menu.
3 Check the preferences you want:

Dual View. Displays two views of a palette, each of which can display a different viewing order. When you 
check this option, PalEdit shows colors you select in both views.

Delay Updates. Prevents PalEdit from automatically reflecting the changes you make to a palette in BitEdit. 
When you check this option, PalEdit does not recalculate the palette for each bitmap change, so you don't have to 
wait for the palette to update before continuing.

4 Click OK.

Tip When Delay Updates is checked, you can manually update the palette in PalEdit by selecting a viewing order.



Step-by-step
Changing the palette view
Opening PalEdit



Changing the palette view
Step-by-step

You can change the order that colors display in PalEdit by selecting a viewing order. Changing the viewing order 
affects only the display of the palette, not the contents of the palette file.

To change to a different viewing order:
1 In PalEdit, click the arrow to the right of the viewing order box.
2 Select the viewing order you want:

Palette Order. Colors display in the order they are stored in the palette file.

Brightness. Lightest colors display at the top, darkest at the bottom, from left to right.

Darkness. Darkest colors display at the top, lightest at the bottom, from left to right.

Color Sort. Colors with similar RGB values display together.

Bitmap Occurrence. Only available when you open PalEdit from BitEdit. Colors display in order of frequency 
of appearance in the bitmap.



Step-by-step
Opening PalEdit
Setting preferences



Selecting color cells
Step-by-step

You select a color cell or a range of color cells in PalEdit so that you can cut, move, or copy the selection, or 
change the color values associated with the selection.

To select a single cell:

Click the cell containing the color you want.
To select multiple cells:

Drag the mouse pointer over the cells you want. Or, hold down the Shift key while clicking on each cell you 
want.

To select a row of cells:

Click the left margin of the row you want.
To select all cells in a palette:

Choose Select All from the Edit menu.



Step-by-step
Deselecting color cells
Identifying palette colors in a bitmap
Selecting colors from BitEdit
Selecting similar colors
Selecting unused colors



Deselecting color cells
Step-by-step

You can deselect one or more selected color cells in PalEdit.

To deselect certain selected color cells:

Shift+click the cells you do not want.

Click or drag over the cells you do not want with the right mouse button.
To deselect all selected color cells:

Click in the top, bottom, or right margin.

Click an empty cell.



Step-by-step
Selecting color cells
Selecting colors from BitEdit
Selecting similar colors
Selecting unused colors



Selecting similar colors
Step-by-step

For any selected color cell in PalEdit, you can select other cells containing colors with similar RGB values. For 
example, you can identify similar colors to merge or replace so that you can reduce a palette.

To select a group of similar colors:
1 In PalEdit, select the cell containing the color you want to compare.

If you select more than one cell, PalEdit uses the color in the cell you selected first.
2 Choose Select Similar Colors from the Edit menu.
3 In the Number Of Selected Colors box, enter the number of cells you want to select that contain a similar RGB 

value to the comparison color. You can adjust the group size by moving the scroll bar.
4 Click OK.



Step-by-step
Deselecting color cells
Identifying palette colors in a bitmap
Merging selected color cells
Selecting color cells



Selecting unused colors
Step-by-step

When you open PalEdit from BitEdit, you can select unused colors in the bitmap's palette, then delete them to 
reduce the palette. This function is not available when you open PalEdit as a standalone application or from 
Multimedia ToolBook.

To select unused palette cells:

Choose Select Unused Colors from the Edit menu.



Step-by-step
Deselecting color cells
Deleting color cells
Opening PalEdit
Selecting color cells



Selecting colors from BitEdit
Step-by-step

You can select an area of a bitmap that is open in BitEdit, then open PalEdit to edit or merge the colors contained 
in that area.

To use PalEdit to select colors in a palette open in BitEdit:
1 In BitEdit, select the bitmap area that contains colors you want to modify in PalEdit.
2 To open PalEdit, choose Show Palette from the Options menu.
3 Arrange the BitEdit and PalEdit windows so that you can see both.
4 Choose Select In PalEdit from the BitEdit Selection menu.



Step-by-step
Deselecting color cells
Copying and pasting color cells
Identifying palette colors in a bitmap
Moving color cells
Selecting color cells



Identifying palette colors in a bitmap
Step-by-step

You can select one or more colors in PalEdit and find out where those colors are used in a BitEdit bitmap using 
PalEdits Flash Selected Colors command. BitEdit briefly inverts the selected colors, so that the bitmap areas 
containing those colors appear to flash.

To flash the selected colors once in the bitmap and palette:
1 Open and arrange the PalEdit and BitEdit windows so you can see both.
2 In PalEdit, select the color cells you want.
3 Choose Flash Selected Colors from the Edit menu.



Step-by-step
Deselecting color cells
Selecting color cells
Selecting colors from BitEdit
Selecting similar colors
Selecting unused colors



Editing a color in a palette
Step-by-step

You can change the look of a bitmap image by modifying its colors in PalEdit using the Edit Color command. When
you open PalEdit from BitEdit, you can see how editing colors affects the display of the bitmap associated with the 
open palette.

To edit a color cell:
1 Open PalEdit and open the palette you want to edit.
2 Select the color cell you want to edit.
3 Do one of the following:

Choose Edit Color from the Edit menu.

Double-click the color cell.
4 Define the color you want.
5 When you are satisfied with the color, click OK.



Step-by-step
Adding a color to a palette
Defining a color
Opening PalEdit
Selecting color cells



Defining a color
Step-by-step

When you add or edit a color in PalEdit, you can use RGB values or HSL values to define the color. RGB values 
represent the red, green, and blue components that make up a color. HSL values represent the hue, saturation, 
and luminance components.

To define a color using RGB values:

In the Red, Green, and Blue boxes of the Add Color or Edit Color dialog box, enter a number between 0 and 
255 to specify the amount of each color you want.

As you change the color, the new color is displayed in the Color refiner box.

To define a color using HSL values:
1 For Hue in the Add Color or Edit Color dialog box, enter a number between 0 and 239 to represent a color 

corresponding to its position in the spectrum, ranging from red through yellow, green, cyan, blue, and magenta.
2 For Sat, enter a number between 0 and 239 to represent the intensity of a color.
3 For Lum, enter a number between 0 and 239 to represent the amount of white or black in a color.

As you change the color, the new color is displayed in the Color refiner box.

To choose a color from the color grid:
1 Drag the cursor to the area of the color grid that shows the color you want to refine.
2 Move the slider up or down the vertical bar to adjust the color's luminosity.



Step-by-step
Adding a color to a palette
Editing a color in a palette



Adding a color to a palette
Step-by-step

If a palette has an empty color cell, you can add a new color definition to the palette using PalEdit. For example, 
you can add the color needed for your company logo to a bitmap's palette.

To add a color to a palette:
1 Open PalEdit and open the palette you want to edit.
2 Verify that the palette has an empty color cell.
3 Choose Add Color from the Palette menu.
4 Define the color you want.
5 Click the Add button to add the new color.
6 Click the Close button when you finish adding colors.



Step-by-step
Defining a color
Copying and pasting color cells
Editing a color in a palette
Opening PalEdit



Copying and pasting color cells
Step-by-step

You can copy colors from one palette file and paste them into a different palette file. You can paste the colors into 
empty color cells, or you can replace existing color cells.

To copy and paste color cells as new colors:
1 Open PalEdit and open the first palette.
2 Select the cell or cells you want to copy.
3 Choose Copy from the Edit menu. Or, press Ctrl+Ins.

To paste colors into empty color cells
1 Open the target palette and make sure the viewing order is Palette Order.
2 Choose Paste from the Edit menu.

Note If the palette doesn't have enough empty cells to hold all the colors you are pasting, PalEdit displays a 
message indicating the number of colors that will be truncated if you paste. Click OK to paste, or click Cancel to 
cancel the paste operation.

To replace existing color cells:
1 Make sure the viewing order of the opened palette is Palette Order.
2 Select the cells you want to replace with the pasted colors.
3 Choose Paste from the Edit menu.

If the pasted palette is smaller than the selection, PalEdit replaces the selected cells, then shifts the other 
colors in the palette to fill the empty cells.

If the pasted palette is larger than the selection, PalEdit replaces the selected cells first, then inserts the 
remaining colors to the right of the replacement colors. If the palette doesn't have enough empty cells to hold the 
additional colors, PalEdit displays a message indicating the number of colors that will be truncated if you paste. Click 
OK to paste, or Cancel to cancel the paste operation.



Step-by-step
Deleting color cells
Moving color cells
Opening PalEdit
Selecting color cells



Moving color cells
Step-by-step

You can move the palette colors that are important to a bitmap to the top of the palette file. This ensures that the 
important colors will be preserved if you truncate the palette or create an identity palette.
Tip If you are displaying Dual View, you can move colors from one view to the other.

To move one or more colors:
1 In PalEdit, select the cell or cells containing the color you want to move.
2 Point to the selection, then hold down the left mouse button.
3 Drag the selection to a new location in the palette, indicated by an insertion point.



Step-by-step
Copying and pasting color cells
Reordering an entire palette
Selecting color cells
Setting preferences



Merging selected color cells
Step-by-step

You can select two or more colors and merge them to create a single color that replaces the selected color cells. 
For example, you can select three shades of blue in a bitmap's palette to merge into one median blue shade, 
reducing the palette by two colors without greatly affecting the bitmap's display quality.When you open PalEdit 
from BitEdit, you can see how merging colors affects the display of the bitmap associated with the open palette.

To merge selected color cells:
1 In PalEdit, select the cells containing the colors you want to merge.
2 Choose Merge Selected Colors from the Edit menu.



Step-by-step
Selecting color cells



Deleting color cells
Step-by-step

If a palette contains colors you don't want, you can delete those color cells from the palette. Colors below the 
deleted color cells shift to fill the empty cells; unused cells are placed at the bottom of the palette.
When you open PalEdit from BitEdit, you can see how deleting colors affects the display of the bitmap associated 
with the open palette. If you delete colors used by the bitmap, the deleted bitmap colors are remapped to the 
closest available colors.

To delete color cells from a palette:
1 Select the cells you want to delete.
2 Choose Delete from the Edit menu. Or, press the Delete key.



Step-by-step
Copying and pasting color cells
Merging color cells
Selecting color cells



Adjusting palette brightness
Step-by-step

You can compensate for an overexposed or underexposed bitmap by adjusting the brightness of its palette in 
PalEdit. You can change the RGB values for each color in the palette by a fixed amount that you specify.
When you open PalEdit from BitEdit, you can see how adjusting palette brightness affects the display of the 
bitmap associated with the open palette.

To adjust palette brightness:
1 Open PalEdit and open the palette you want to adjust.
2 Choose Adjust Brightness from the Effects menu.
3 Do one of the following:

Move the slider until you reach the level of brightness you want.

In the Adjustment box, enter a brightness value in RGB units.
4 Click OK.
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Adjusting palette contrast
Step-by-step

You can adjust a palette's contrast to increase or decrease the distinction between light and dark colors. The 
luminance and RGB values for each color in a palette are changed by a percentage you specify.
When you open PalEdit from BitEdit, you can see how adjusting palette contrast affects the display of the bitmap 
associated with the open palette.

To adjust palette contrast:
1 Open PalEdit.
2 Choose Adjust Contrast from the Effects menu.
3 Do one of the following:

Move the slider until you have the level of contrast you want.

In the Adjustment box, enter the percentage of contrast you want.
4 Click OK.
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Tinting or filtering an entire palette
Step-by-step

Tinting a palette adds the RGB values of a specified color to all cells of the palette, causing one color to dominate 
a bitmap. Filtering a palette removes a specified color from all cells of the palette. You can select one color cell to 
use its RGB value to tint or filter the palette. Or, select several color cells to use the average of their RGB values to
tint or filter the palette.
When you open PalEdit from BitEdit, you can see how tinting or filtering affects the display of the bitmap 
associated with the open palette.

To tint or filter a palette:
1 Open PalEdit and open the palette you want to tint or filter.
2 Select the color cell or cells you want.
3 Choose Add Selected Color from the Effects menu.
4 Move the slider right to choose the percentage of the selected color with which you want to tint the palette.

Move the slider left to choose the percentage of the selected color you want to filter out of the palette.
Or, in the Percentage box, enter the percentage of tinting or filtering you want.

4 Click OK.
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Fading a palette to a specific color
Step-by-step

You can fade colors in a palette, which converges all the colors in a palette toward one color or a selection of 
colors. For example, if you fade to 50 percent blue, every color in a palette changes to the color halfway between 
the original color and blue.
If you select one color, PalEdit fades the palette using the RGB values of the selected color. If you select more 
than one color, PalEdit uses the average of RGB values of the selected colors.
When you open PalEdit from BitEdit, you can see how fading affects the display of the bitmap associated with the 
open palette.

To fade a palette to a selected color:
1 Open PalEdit and open the palette you want to fade.
2 Select one or more color cells in the palette.
3 Choose Fade To Selected Color from the Effects menu.
4 Move the slider right to increase the percentage of fading you want. Or, in the Percentage box, enter the 

percentage of fading you want.
5 Click OK.
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Fading a palette to a second palette
Step-by-step

You can fade the colors of one palette to the colors of a second palette. For each color cell of the currently 
displayed palette, PalEdit selects a target color (the closest matching color) from the second palette and 
transforms the color cell to that target color.
When you open PalEdit from BitEdit, you can see how fading affects the display of the bitmap associated with the 
open palette.

To fade a palette to a second palette:
1 Open PalEdit and open the palette you want to fade.
2 Choose Fade To Palette from the Effects menu.
3 Select a bitmap or palette file from which PalEdit will select the target colors, then click OK.
4 Move the slider right to increase the percentage of fading you want. Or, in the Percentage box, enter the 

percentage of fading you want.
5 Click OK.
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Cycling hue sequences in a palette
Step-by-step

To change the overall color scheme of the bitmap, you can cycle all the color definitions in a palette through all the 
hues in a color wheel by a fixed amount. PalEdit shifts the hue for all colors in a palette by the same amount. 
White, gray, and black are not affected by this command.
When you open PalEdit from BitEdit, you can see how cycling affects the display of the bitmap associated with the 
open palette.

To cycle RGB values in a palette:
1 Open PalEdit and open the palette you want to cycle.
2 Choose Cycle RGB from the Effects menu.
3 Move the slider right to increase the percentage of hue shift you want. Or, in the Percentage box, enter the 

percentage of hue shift you want.
Labels on the slider mark the points where the hue shifts to produce a new color. For example, at 33, shades of
red shift to shades of green, and shades of cyan shift to shades of yellow.
Other percentages produce colors located between adjacent primary or secondary colors of the color wheel.
The values 0 and 100 leave the palette unchanged.

4 Click OK.
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Cycling palette colors
Step-by-step

You can cycle colors in a palette, shifting color definitions from cell to cell to test the effect of different color 
sequences on a static or animated image.
When you open PalEdit from BitEdit, you can see how cycling affects the display of the bitmap associated with the 
open palette.

To cycle palette colors:
1 Open PalEdit and open the palette you want to cycle.
2 Reorder the color cells in the palette to create the color sequence you want.
3 Select the first and last color cells of the sequence you want to cycle.
4 Choose Cycle Palette from the Effects menu.
5 Move the slider right to cycle the color sequence. Or, in the Percentage box, enter the amount you want to 

cycle as a percentage of the sequence.
6 When you have cycled through the sequence you want, click OK.
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Reordering an entire palette
Step-by-step

You can reorder the entire structure of a palette to match a viewing order. The procedure varies slightly depending 
on whether you are displaying the palette in single or dual view.
When you open PalEdit from BitEdit, reordering the palette does not affect the display of the bitmap associated 
with the open palette.

To reorder a palette:
1 Open PalEdit and open the palette you want to reorder.
2 Select the viewing order you want.
3 If you are displaying:

a single view, choose Reorder Palette As View from the Palette menu.

a dual view, choose Copy View from the Palette menu.
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Creating an identity palette
Step-by-step

To load a 256-color bitmap faster in your application, you can convert its palette into an identity palette that 
contains the 20 system colors reserved by Windows in addition to the bitmap's colors. PalEdit inserts the reserved 
system colors into the first 10 and last 10 cells of a 256-color palette.
If your palette contains more than 236 colors, using the Make Identity Palette command causes PalEdit to truncate
the palette's bottom 20 colors to make room for the system colors; then PalEdit remaps deleted colors to the 
closest remaining colors in the palette.

To create an identity palette:
1 Open PalEdit and open the palette you want to convert.
2 Change the viewing sequence to Palette Order.
3 Choose Make Identity Palette from the Palette menu.
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Identity palette
A palette specific to a bitmap that contains 236 bitmap colors and 20 system colors (10 at the top of the palette and 
10 at the bottom). Creating an identity palette for a bitmap allows the bitmap to load faster.
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Calling Technical Support
Step by step

Registered Asymetrix product users receive 30 days of complimentary technical support, beginning with their first 
call to Asymetrix Technical Support. Phone support can be extended beyond the complimentary period by 
purchasing a technical support contract.
Use the appropriate Asymetrix technical support telephone numbers for your location as listed below.

Australia/Asia Pacific

    Infotainment Asia Pacific Pty Ltd.
(61+3) 5255-471 (direct)
(61+3) 5255-482 (fax)

9 a.m. to 6 p.m. Eastern Standard Time

    XLTECH Pty Ltd.
(61+2) 9752-111 (direct)
(61+2) 9752-167 (fax)

9 a.m. to 6 p.m. Eastern Standard Time

Europe (except France, Germany, and United Kingdom); Middle East; Africa; 
Russia

(44) 1923-208433
(44) 1923-208419 (fax)

9:00 to 17:00 GMT

France
05-90-83-19 (freephone)
(44) 1923-208419 (fax)

9:00 to 17:00 GMT

Germany
01-30-81-27-07 (freephone)
(44) 1923-208419 (fax)

9:00 to 17:00 GMT

United Kingdom
0800-716957 (freephone)
(44) 1923-208419 (fax)

9:00 to 17:00 GMT

U.S.A. and rest of world
(206) 637-1600 (direct)
(206) 454-0672 (fax)

6 a.m. to 6 p.m. Pacific time, Monday through Thursday; 6 
a.m. to 3 p.m. Friday

When you call Technical Support, please be at your computer with your Asymetrix documentation and have the 
following information:

Your Asymetrix product serial number (found on the first installation disk, your license agreement envelope, 
or your Asymetrix product box).

The version of the Asymetrix product you are running.

Your system configuration information (you can find this information by choosing System Info from the Help 
menu, or by double-clicking the System Info icon in the Asymetrix product program group, located in the Program 
Manager; or by double-clicking Windows Setup, located in the Program Manager in the Main group).

The exact wording of any error message you have encountered.

What happened and what you were doing when the problem occurred.

How you tried to solve the problem.
When you leave a message or send a fax, please include the information listed above. A technical support 



representative will respond within two business days to messages sent and faxes left before or after business 
hours.
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Using the Asymetrix Bulletin Board System (BBS)
Step by step

You can receive online technical support on the Asymetrix Bulletin Board System (BBS) by leaving a message for 
the Asymetrix System Operator. The System Operator checks the BBS daily for new messages and answers them 
within two business days (Monday through Friday). To help the System Operator answer your question, gather 
information about your system as described in Step 5 below.
The data configuration for the BBS is: no parity, 8 data bits, 1 stop bit.

To connect to the Asymetrix Bulletin Board System:
1 Call the Asymetrix BBS number:

If you have a 1200 to 9600 baud modem (v.32bis), call (206) 451-1173.

If you have a 9600 to 14,400 baud modem (v.32bis), call (206) 451-8290.
2 Enter your first and last names at the prompts.

If you are a new BBS user and you see a welcome message, there is probably another user with the same 
name. Hang up the phone, redial, and use a different name, such as "Jim" instead of "James," or include your 
middle initial.

3 Enter your password, then retype it to confirm its spelling.
4 If you are a new user, complete the new user questionnaire.

Make sure you have your Asymetrix product serial number (found on the first installation disk, your license 
agreement envelope, or your Asymetrix product box). You will be asked about your software and hardware. 
Where applicable, it is recommended that you accept the defaults.

5 To leave a message for the System Operator, type C for "Comments to the sysop," then leave a message 
containing the following information:

All the information gathered about your system configuration. For details on gathering this information, see 
instructions below.

The version of DOS you are running.

The version of Windows you are running.

The version of the Asymetrix product you are running.

The exact wording of any error message you have encountered.

What happened and what you were doing when the problem occurred.

How you tried to solve the problem.
6 To log off the BBS, type G for "Goodbye," then type Y to confirm.

Tip At any time, you can type "?" to get online command help. If you have any problems or difficulties with the 
Asymetrix BBS, leave a message for the BBS System Operator or call the Asymetrix Technical Support line at 
(206) 637-1600.

To gather system configuration information for the System Operator:
1 Choose System Info from the Help menu. If you cannot run your Asymetrix product, double-click the System 

Info icon in the product's program group, located in the Program Manager.
2 Copy down all the information listed in the System Status box.



Step by step
Calling Technical Support
Using America Online
Using CompuServe
Using Internet
Using the Fax Back System
Using the World Wide Web



Using CompuServe
Step by step

If you are a CompuServe member, you can receive online technical support by leaving a message for the 
Asymetrix Forum Moderator. The Forum Moderator checks CompuServe daily for new messages and answers 
them within two business days (Monday through Friday). To help the Forum Moderator answer your question, 
gather information about your system as described in Step 3 below.
Refer to your CompuServe documentation for step-by-step instructions for logging onto CompuServe, leaving 
messages for the Forum Moderator, and logging off CompuServe.

To connect to CompuServe:
1 Log on to CompuServe.
2 To connect to

Windows Third Party Developer A forum, Section 1, type GO ASYMETRIX or GO WINAPA at the prompt.

Multimedia Vendors forum, Section 15, type GO MULTIVEN at the prompt.

IBM Ultimedia Tools A forum, Section 5, type GO ULTIATOOLS at the prompt.
3 In the Asymetrix section (Section 1), leave a message for the Forum Moderator containing the following 

information:

All the information gathered about your system configuration. For details on gathering this information, see 
instructions below.

Your Asymetrix product serial number (found on the first installation disk, your license agreement envelope, 
or your Asymetrix product box) and version.

The version of DOS you are running.

The version of Windows you are running.

The exact wording of any error message you have encountered.

What happened and what you were doing when the problem occurred.

How you tried to solve the problem.
4 Log off CompuServe.

To gather system configuration information for the Forum Moderator:
1 Choose System Info from the Help menu. If you cannot run your Asymetrix product, double-click the System 

Info icon in the product's program group, located in the Program Manager.
2 Copy down all the information listed in the System Status box.
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Using America Online
Step by step

If you are an America Online member, you can receive online technical support by leaving a message for the 
Asymetrix Forum Moderator. The Forum Moderator checks America Online daily for new messages and answers 
them within two business days (Monday through Friday). To help the Forum Moderator answer your question, 
gather information about your system as described in Step 3 below.
Refer to your America Online documentation for step-by-step instructions for logging onto America Online, leaving 
messages for the Forum Moderator, and logging off America Online.

Note America Online operates a text telephone (TDD) for deaf or hearing-impaired members.

To connect to America Online:
1 Log on to America Online.
2 Do one of the following:

From the Go To menu, select Keyword, then type Asymetrix.

Go to the Computing and Software area, select Industry Connection, then select Asymetrix.
3 Leave a message for the Forum Moderator containing the following information:

All the information gathered about your system configuration. For details on gathering this information, see 
instructions below.

Your Asymetrix product serial number (found on the first installation disk, your license agreement envelope, 
or your Asymetrix product box) and version.

The version of DOS you are running.

The version of Windows you are running.

The exact wording of any error message you have encountered.

What happened and what you were doing when the problem occurred.

How you tried to solve the problem.
4 Log off America Online.

Tip You can receive the software required to use America Online at no cost, plus five complimentary hours of 
online time. For details about America Online, call (800) 827-6364 or (703) 893-6288.

To gather system configuration information for the Forum Moderator:
1 Choose System Info from the Help menu. If you cannot run your Asymetrix product, double-click the System 

Info icon in the product's program group, located in the Program Manager.
2 Copy down all the information listed in the System Status box.
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Using Internet
Step by step

If you have access to Internet mail, you can receive online technical support by leaving a message for the 
Asymetrix Forum Moderator. The Forum Moderator checks Internet daily for new messages and answers them 
within two business days (Monday through Friday). To help the Forum Moderator answer your question, gather 
information about your system as described in Step 3 below.
Refer to your electronic mail documentation for step-by-step instructions about starting mail and sending 
messages on Internet.

To access Internet:
1 Start your electronic mail application.
2 In the box where you enter the receiver's address, type support@asymetrix.com or 

techsup@asymetrix.com.
3 Leave a message for the Forum Moderator containing the following information:

All the information gathered about your system configuration. For details on gathering this information, see 
instructions below.

Your Asymetrix product serial number (found on the first installation disk, your license agreement envelope, 
or your Asymetrix product box) and version.

The version of DOS you are running.

The version of Windows you are running.

The exact wording of any error message you have encountered.

What happened and what you were doing when the problem occurred.

How you tried to solve the problem.
4 Send your message.

To gather system configuration information for the Forum Moderator:
1 Choose System Info from the Help menu. If you cannot run your Asymetrix product, double-click the System 

Info icon in the product's program group, located in the Program Manager.
2 Copy down all the information listed in the System Status box.
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Using the Fax on Demand System
Step by step

If you have a fax machine, you can receive answers to frequently asked questions from the Asymetrix Fax on 
Demand System, which is available 24 hours a day.

To use the Fax on Demand System:
1 From your fax machine or regular phone, dial (800) 770-5444 or (206) 637-5833.
2 If you do not have a list of available fax documents, or if the list you have is old, follow the directions in the Fax 

on Demand System's recording to receive a list. The list is updated frequently.
If you have a current list of available documents, follow the directions in the Fax on Demand System's recording
to receive up to three fax documents.

3 If you are calling from a regular phone, the Fax Back System will prompt you to enter your fax machine phone 
number. Enter a '"1" and your area code, followed by your phone number.
If you are calling from a fax machine phone, the system will automatically fax to that number.
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Using the World Wide Web
Step by step

If you are have access to the World Wide Web (WWW), you can receive online technical information and technical
support at the Asymetrix Web site. The Asymetrix Internet Tech Center Web page provides access to

answers to frequently asked questions (FAQ), organized by product.

the Asymetrix FTP (file transfer protocol) site, which includes an index of the names, size, details, and 
locations of all Asymetrix FTP files.

Asymetrix online technical support, where you can leave a message. You message will be answered within 
two business days (Monday through Friday).

To access the Asymetrix web site:
1 Load your Windows Web browser (for example, NetScape or Mosaic).
2 Enter the location (URL) of the Asymetrix web site:

http://www.asymetrix.com.

To reach the Asymetrix Internet Tech Center Web page:
1 Click the Technical Services button on the Asymetrix main menu graphic.
2 Click the "Internet Tech Center" hyperlink.
3 Click the appropriate hyperlink to go to FAQ, the Asymetrix FTP site, or technical support.
4 If you click the "Submit a problem or suggestion to Asymetrix's Technical Support" hyperlink to go to technical 

support, enter your contact information, as well as the details of your problem, including the following 
information:

All the information gathered about your system configuration. For details on gathering this information, see 
instructions below.

Your Asymetrix product serial number (found on the first installation disk, your license agreement envelope, 
or your Asymetrix product box) and version.

The version of DOS you are running

The version of Windows you are running

The exact wording of any error message you have encountered

What happened and what you were doing when the problem occurred

How you tried to solve the problem
To gather system configuration information for the Forum Moderator:
1 Choose System Info from the Help menu. If you cannot run your Asymetrix product, double-click the System 

Info icon in the product's program group, located in the Program Manager.
2 Copy down all the information listed in the System Status box.



Step by step
Calling Technical Support
Using America Online
Using CompuServe
Using Internet
Using the Asymetrix Bulletin Board System (BBS)
Using the Fax Back System



 




